تنفيذ أوامر عن بُعد — CVE-2026-2052
تؤثر هذه الثغرة الموثقة في راجع نشرات المورّد المرتبطة بسجل CVE. يوضح سجل NVD أن المشكلة تتمثل في: The Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.2 via the Display Logic feature. This is due to the plugin using eval() on user-supplied Display Logic expressions with an insufficient blocklist/allowlist that can be bypassed using array_map with string concatenation, combined with a lack of authorization enforcement on the extended_widget_opts_block attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server. The vulnerability was partially patched in version 4.2.0.
ماذا تفعل هذه الثغرة؟
هذه الثغرة هي حالة ضعف موثقة في مكوّن برمجي. قد تسمح آثارها بالوصول غير المصرح به أو كشف المعلومات أو التأثير في الخدمة بحسب المنتج المتأثر، وإعداداته، وصلاحيات المهاجم. يوضح الوصف أعلاه طبيعة المشكلة، بينما تساعد درجة CVSS على تقدير مستوى الخطر وترتيب أولوية المعالجة.
الأنظمة المتأثرة
بيانات الثغرة
- النوع
- تنفيذ أوامر عن بُعد
- مستوى الخطورة
- عالي
- درجة CVSS
- 8.8
- تاريخ الاكتشاف
- 2026-05-02
الحماية والتوصيات
تحديث النظام المتأثر إلى آخر إصدار مدعوم.
الوصول إلى ملف الثغرة
هذه الثغرة ضمن الثغرات عالية الخطورة. للحصول على الخدمة والتفاصيل التجارية، تواصل معنا مباشرة عبر واتساب.
السعر