حقن JavaScript (XSS) — CVE-2026-44581
تؤثر هذه الثغرة الموثقة في vercel next.js. يوضح سجل NVD أن المشكلة تتمثل في: Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.
ماذا تفعل هذه الثغرة؟
هذه الثغرة هي حالة ضعف موثقة في مكوّن برمجي. قد تسمح آثارها بالوصول غير المصرح به أو كشف المعلومات أو التأثير في الخدمة بحسب المنتج المتأثر، وإعداداته، وصلاحيات المهاجم. يوضح الوصف أعلاه طبيعة المشكلة، بينما تساعد درجة CVSS على تقدير مستوى الخطر وترتيب أولوية المعالجة.
الأنظمة المتأثرة
- vercel next.js
بيانات الثغرة
- النوع
- حقن JavaScript (XSS)
- مستوى الخطورة
- متوسط
- درجة CVSS
- 4.7
- تاريخ الاكتشاف
- 2026-05-13
الحماية والتوصيات
تثبيت التحديث الأمني الصادر عن مورّد vercel next.js فور توفره، وتقليل تعرّض الخدمة للشبكة، وتفعيل المراقبة والتنبيهات المناسبة. استخدم هذه المعلومات داخل نطاق دفاعي ومصرح به فقط.
الوصول إلى ملف الثغرة
لا يوجد ملف أصلي مطابق لهذه الثغرة متاح للتنزيل حاليًا. لن نعرض ملفًا عامًا أو غير متعلق بها حفاظًا على دقة المحتوى.
السعر