حقن JavaScript (XSS) — CVE-2026-44580
تؤثر هذه الثغرة الموثقة في vercel next.js. يوضح سجل NVD أن المشكلة تتمثل في: Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
ماذا تفعل هذه الثغرة؟
هذه الثغرة هي حالة ضعف موثقة في مكوّن برمجي. قد تسمح آثارها بالوصول غير المصرح به أو كشف المعلومات أو التأثير في الخدمة بحسب المنتج المتأثر، وإعداداته، وصلاحيات المهاجم. يوضح الوصف أعلاه طبيعة المشكلة، بينما تساعد درجة CVSS على تقدير مستوى الخطر وترتيب أولوية المعالجة.
الأنظمة المتأثرة
- vercel next.js
بيانات الثغرة
- النوع
- حقن JavaScript (XSS)
- مستوى الخطورة
- متوسط
- درجة CVSS
- 6.1
- تاريخ الاكتشاف
- 2026-05-13
الحماية والتوصيات
تثبيت التحديث الأمني الصادر عن مورّد vercel next.js فور توفره، وتقليل تعرّض الخدمة للشبكة، وتفعيل المراقبة والتنبيهات المناسبة. استخدم هذه المعلومات داخل نطاق دفاعي ومصرح به فقط.
الوصول إلى ملف الثغرة
لا يوجد ملف أصلي مطابق لهذه الثغرة متاح للتنزيل حاليًا. لن نعرض ملفًا عامًا أو غير متعلق بها حفاظًا على دقة المحتوى.
السعر